•   Login
  •  
  •   Rss
  •   Rss2.0
  •   ATOM1.0
  •   Admin
  •   Top
  •   Home

Debian GNU/Linux アップグレード、無事完了
vdpau-va-driver:amd64 は以下に依存 (depends) します: libva-driver-abi-1.0 ...しかし:。
Debian GNU/Linux アップグレードに失敗  -- 2020-03-07 Saturday

これの続きです。
2ヶ月近く放置していたのですが、だんだん怖くなってきたので、GW期間中に本気で解決しにかかりました。
いつものお呪いのログです。(非常に長いのでところどころ割愛しています。)
hoge@samurai:# aptitude update
[ 0%] 拡張状態情報を書き込んでいます
[100%] 拡張状態情報を書き込んでいます

【割愛】

[ 0%] パッケージリストを読み込んでいます
[ 59%] パッケージリストを読み込んでいます
[100%] パッケージリストを読み込んでいます
[ 0%] パッケージリストを読み込んでいます
[ 0%] 依存関係ツリーを作成しています
[ 50%] 依存関係ツリーを作成しています
[100%] 依存関係ツリーを作成しています
[ 0%] 状態情報を読み取っています
[ 11%] 状態情報を読み取っています
[ 22%] 状態情報を読み取っています
[ 56%] 状態情報を読み取っています
[100%] 状態情報を読み取っています
[ 0%] 拡張状態情報を読み込んでいます
[100%] 拡張状態情報を読み込んでいます
[ 0%] パッケージの状態を初期化しています
[100%] パッケージの状態を初期化しています
[ 0%] 拡張状態情報を書き込んでいます
[100%] 拡張状態情報を書き込んでいます
[ 0%] タグのデータベースを構築しています
[100%] タグのデータベースを構築しています

hoge@samurai:# aptitude dist-upgrade -y
[ 0%] パッケージリストを読み込んでいます
[100%] パッケージリストを読み込んでいます
[ 0%] 依存関係ツリーを作成しています
[ 50%] 依存関係ツリーを作成しています
[100%] 依存関係ツリーを作成しています
[ 0%] 状態情報を読み取っています
[ 11%] 状態情報を読み取っています
[ 22%] 状態情報を読み取っています
[ 56%] 状態情報を読み取っています
[100%] 状態情報を読み取っています
[ 0%] 拡張状態情報を読み込んでいます
[100%] 拡張状態情報を読み込んでいます
[ 0%] パッケージの状態を初期化しています
[100%] パッケージの状態を初期化しています
[ 0%] 拡張状態情報を書き込んでいます
[100%] 拡張状態情報を書き込んでいます
[ 0%] タグのデータベースを構築しています
[100%] タグのデータベースを構築しています
以下の新規パッケージがインストールされます:
apparmor{a} dbus-user-session{a} dns-root-data{a} dwz{a} gcc-7-base{a}

【割愛】

以下のパッケージが削除されます:
php-php-gettext{u}
以下のパッケージが更新されます:
【割愛】

以下の、インストールが完了していないパッケージが設定されます:
【割愛】
以下のパッケージが推奨されていますがインストールされません:
【割愛】
更新: 669 個、新規インストール: 158 個、削除: 1 個、保留: 0 個。
アーカイブの 141 MB/624 MB を取得する必要があります。展開後に 1,035 MB のディスク領域が新たに消費されます。
以下のパッケージには満たされていない依存関係があります:
【割愛】
以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:
1) libanthy0 [9100h-25+b2 (now)]
2) libcurl3 [7.52.1-5+deb9u9 (now)]
3) libtirpc1 [0.2.5-1.2+deb9u1 (now)]
4) mariadb-client-10.1 [10.1.44-0+deb9u1 (now)]
5) mariadb-client-core-10.1 [10.1.44-0+deb9u1 (now)]
6) mariadb-server-10.1 [10.1.44-0+deb9u1 (now)]
7) mariadb-server-core-10.1 [10.1.44-0+deb9u1 (now)]
8) mysql-server [5.5.9999+default (now)]
9) php7.0-curl [7.0.33-0+deb9u6 (now)]
10) phpmyadmin [4:4.6.6-4 (now)]
11) uim-qt [1:1.8.6+gh20161003.0.d63dadd-2 (now)]
12) uim-utils [1:1.8.6+gh20161003.0.d63dadd-2 (now)]

以下のパッケージをインストールする:
13) libanthyinput0 [1:0.3-8.1 (stable)]



この解決方法を受け入れますか? [Y/n/q/?]Y
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが削除されます:
【割愛】
以下のパッケージが更新されます:
【割愛】
以下の、インストールが完了していないパッケージが設定されます:
anthy uim-mozc vdpau-va-driver
以下のパッケージが推奨されていますがインストールされません:
【割愛】
更新: 661 個、新規インストール: 139 個、削除: 26 個、保留: 0 個。
アーカイブの 127 MB/610 MB を取得する必要があります。展開後に 783 MB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] Y
[ 0%] 拡張状態情報を書き込んでいます
[100%] 拡張状態情報を書き込んでいます
【割愛】
.../uim-data_1%3a1.8.8-4+deb10u2_all.deb を展開する準備をしています ...
uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を設定削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: アーカイブ /var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u2_all.deb の処理中にエラーが発生しました (--unpack):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
処理中にエラーが発生しました:
/var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: 依存関係の問題により vdpau-va-driver:amd64 の設定ができません:
vdpau-va-driver:amd64 は以下に依存 (depends) します: libva-driver-abi-1.0 ...しかし:
パッケージ libva-driver-abi-1.0 はまだインストールされていません。

dpkg: パッケージ vdpau-va-driver:amd64 の処理中にエラーが発生しました (--configure):
依存関係の問題 - 設定を見送ります
dpkg: 依存関係の問題により anthy の設定ができません:
anthy は以下に依存 (depends) します: libanthyinput0 ...しかし:
パッケージ libanthyinput0 はまだインストールされていません。

dpkg: パッケージ anthy の処理中にエラーが発生しました (--configure):
依存関係の問題 - 設定を見送ります
処理中にエラーが発生しました:
vdpau-va-driver:amd64
anthy
[ 0%] パッケージリストを読み込んでいます
【割愛】
[100%] タグのデータベースを構築しています

hoge@samurai:#

とりあえず、anthyが悪さしているのだろうと思っていたのですが、どうやら違っていました。
apt --fix-broken install で壊れているアプリのインストールを試みてみます。

hoge@samurai:# apt --fix-broken install
パッケージリストを読み込んでいます... 0%パッケージリストを読み込んでいます... 100%パッケージリストを読み込んでいます... 完了
【割愛】
依存関係を解決しています ... 完了
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
【割愛】
これを削除するには 'apt autoremove' を利用してください。
以下の追加パッケージがインストールされます:
【割愛】
提案パッケージ:
gvfs qt5-image-formats-plugins qtwayland5
以下のパッケージは「削除」されます:
libanthy0 uim-qt uim-utils
以下のパッケージが新たにインストールされます:
libanthyinput0 libegl-mesa0 libegl1 libicu63 libpcre2-16-0 libqt5gui5
libqt5svg5 libqt5x11extras5 libva2 libwayland-egl1 qt5-gtk-platformtheme uim
uim-data uim-gtk2.0-immodule uim-gtk3-immodule uim-plugins uim-qt5
uim-qt5-immodule uim-xim
以下のパッケージはアップグレードされます:
【割愛】
アップグレード: 22 個、新規インストール: 19 個、削除: 3 個、保留: 647 個。
3 個のパッケージが完全にインストールまたは削除されていません。
22.4 MB 中 0 B のアーカイブを取得する必要があります。
この操作後に追加で 52.7 MB のディスク容量が消費されます。
続行しますか? [Y/n] Y
パッケージからテンプレートを展開しています: 73%パッケージからテンプレートを展開しています: 100%

dpkg: `uim-data' のインストール によって壊れた uim-anthy の設定削除を考えています ...
dpkg: 問題ありません。(uim-data によって壊れた) uim-anthy の設定削除をします
【割愛】
.../uim-data_1%3a1.8.8-4+deb10u2_all.deb を展開する準備をしています ...
進捗: [ 0%] [............................................................] uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を設定削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: アーカイブ /var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u2_all.deb の処理中にエラーが発生しました (--unpack):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
処理中にエラーが発生しました:
/var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u2_all.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)

どうやら、uim-data と uim-anthy が原因だと突き止めました。
取りあえず、リムーブすることで試みてみます。

hoge@samurai:# aptitude remove uim-anthy uim-data
[ 0%] パッケージリストを読み込んでいます
【割愛】
uim-data パッケージはインストールされていないので削除されません
以下のパッケージが削除されます:
uim-anthy
以下の、インストールが完了していないパッケージが設定されます:
anthy{b} uim-mozc vdpau-va-driver{b}
更新: 0 個、新規インストール: 0 個、削除: 1 個、保留: 668 個。
アーカイブの 0 B を取得する必要があります。展開後に 212 kB のディスク領域が解放されます。
以下のパッケージには満たされていない依存関係があります:
uim-utils : 依存: libuim-plugins (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

uim-fep : 依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

libuim-scm0 : 依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

vdpau-va-driver : 依存: libva-driver-abi-1.0 以下のパッケージから提供されている仮想パッケージです:
- libva2 (2.4.0-1), インストールされません

libuim-custom2 : 依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

libqt5widgets5 : 依存: libqt5gui5 (>= 5.7.0) インストールされません
libuim8 : 依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

uim-gtk3 : 依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

uim-gtk2.0 : 依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

anthy : 依存: libanthyinput0 インストールされません
uim-qt : 依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:

1) libanthy0 [9100h-25+b2 (now)]

2) libqt5widgets5 [5.7.1+dfsg-3+deb9u2 (now)]
3) uim-qt [1:1.8.6+gh20161003.0.d63dadd-2 (now)]
4) uim-utils [1:1.8.6+gh20161003.0.d63dadd-2 (now)]

以下のパッケージをインストールする:

【割愛】

以下のパッケージを更新する:
【割愛】

Leave the following dependencies unresolved:
24) uim が uim-qt5 (>= 1:1.8.8-4+deb10u2) を推奨
25) task-japanese-desktop が uim-anthy を推奨



この解決方法を受け入れますか? [Y/n/q/?]Y
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが削除されます:
libanthy0{a} libqt5widgets5{a} uim-anthy uim-qt{a} uim-utils{a}
以下のパッケージが更新されます:
【割愛】

以下の、インストールが完了していないパッケージが設定されます:
【割愛】
以下のパッケージが推奨されていますがインストールされません:
uim-qt5
更新: 11 個、新規インストール: 8 個、削除: 5 個、保留: 656 個。
アーカイブの 0 B/3,935 kB を取得する必要があります。展開後に 2,554 kB のディスク領域が解放されます。
先に進みますか? [Y/n/?] Y
[ 0%] 拡張状態情報を書き込んでいます
[100%] 拡張状態情報を書き込んでいます
【割愛】
uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: パッケージ uim-anthy の処理中にエラーが発生しました (--remove):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
処理中にエラーが発生しました:
uim-anthy
E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: 依存関係の問題により vdpau-va-driver:amd64 の設定ができません:
vdpau-va-driver:amd64 は以下に依存 (depends) します: libva-driver-abi-1.0 ...しかし:
パッケージ libva-driver-abi-1.0 はまだインストールされていません。

dpkg: パッケージ vdpau-va-driver:amd64 の処理中にエラーが発生しました (--configure):
依存関係の問題 - 設定を見送ります
dpkg: 依存関係の問題により anthy の設定ができません:
anthy は以下に依存 (depends) します: libanthyinput0 ...しかし:
パッケージ libanthyinput0 はまだインストールされていません。

dpkg: パッケージ anthy の処理中にエラーが発生しました (--configure):
依存関係の問題 - 設定を見送ります
処理中にエラーが発生しました:
vdpau-va-driver:amd64
anthy/blockquote>

ちょっと進みました。しかし、まだ、libva-driver-abi-1.0 vdpau-va-driver:amd64の2つが原因のようなので、こいつも削除します。

hoge@samurai:# aptitude remove libva-driver-abi-1.0 vdpau-va-driver
【割愛】
以下のパッケージが削除されます:
vdpau-va-driver
以下の、インストールが完了していないパッケージが設定されます:
anthy{b} uim-mozc
更新: 0 個、新規インストール: 0 個、削除: 1 個、保留: 669 個。
アーカイブの 0 B を取得する必要があります。展開後に 114 kB のディスク領域が解放されます。
以下のパッケージには満たされていない依存関係があります:
【割愛】
anthy : 依存: libanthyinput0 インストールされません
uim-qt : 依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:

1) libanthy0 [9100h-25+b2 (now)]

2) uim-qt [1:1.8.6+gh20161003.0.d63dadd-2 (now)]
3) uim-utils [1:1.8.6+gh20161003.0.d63dadd-2 (now)]

以下のパッケージをインストールする:

【割愛】

以下のパッケージを更新する:

【割愛】
Leave the following dependencies unresolved:
【割愛】



この解決方法を受け入れますか? [Y/n/q/?]Y
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが削除されます:
libanthy0{a} uim-qt{a} uim-utils{a} vdpau-va-driver
以下のパッケージが更新されます:
【割愛】
uim-gtk3
以下の、インストールが完了していないパッケージが設定されます:
【割愛】
以下のパッケージが推奨されていますがインストールされません:
【割愛】
更新: 22 個、新規インストール: 17 個、削除: 4 個、保留: 647 個。
アーカイブの 0 B/24.2 MB を取得する必要があります。展開後に 70.5 MB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] Y
【割愛】
以前に未選択のパッケージ mesa-va-drivers:amd64 を選択しています。
.../mesa-va-drivers_18.3.6-2+deb10u1_amd64.deb を展開する準備をしています ...
mesa-va-drivers:amd64 (18.3.6-2+deb10u1) を展開しています...
dpkg: vdpau-va-driver:amd64: 依存関係に問題があります。しかし要求に従い削除しています:
va-driver-all:amd64 は以下に依存 (depends) します: mesa-va-drivers | vdpau-va-driver ...しかし:
パッケージ mesa-va-drivers:amd64 はまだ設定されていません。
パッケージ vdpau-va-driver:amd64 は削除されようとしています。

【割愛】
vdpau-va-driver:amd64 (0.7.4-7) を削除しています ...
dpkg: `uim-data' のインストール によって壊れた uim-anthy の設定削除を考えています ...
dpkg: 問題ありません。(uim-data によって壊れた) uim-anthy の設定削除をします
【割愛】
.../uim-data_1%3a1.8.8-4+deb10u2_all.deb を展開する準備をしています ...
uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を設定削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: アーカイブ /var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u2_all.deb の処理中にエラーが発生しました (--unpack):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
処理中にエラーが発生しました:
/var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u2_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: 依存関係の問題により anthy の設定ができません:
anthy は以下に依存 (depends) します: libanthyinput0 ...しかし:
パッケージ libanthyinput0 はまだインストールされていません。

dpkg: パッケージ anthy の処理中にエラーが発生しました (--configure):
依存関係の問題 - 設定を見送ります
libva2:amd64 (2.4.0-1) を設定しています ...
mesa-va-drivers:amd64 (18.3.6-2+deb10u1) を設定しています ...
libc-bin (2.28-10) のトリガを処理しています ...
処理中にエラーが発生しました:
anthy
【割愛】
現在の状態: 11 個 (-1) 破損。


これで、anthyが削除出来そうだ。と言う事で、削除を実行!

hoge@samurai:# aptitude remove vdpau-va-driver anthy
[ 0%] パッケージリストを読み込んでいます
【割愛】
vdpau-va-driver パッケージはインストールされていないので削除されません
vdpau-va-driver パッケージはインストールされていないので削除されません
以下のパッケージが削除されます:
anthy libanthy1{u}
以下の、インストールが完了していないパッケージが設定されます:
【割愛】
更新: 0 個、新規インストール: 0 個、削除: 2 個、保留: 669 個。
アーカイブの 0 B を取得する必要があります。展開後に 442 kB のディスク領域が解放されます。
以下のパッケージには満たされていない依存関係があります:
【割愛】

以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:

1) libqt5widgets5 [5.7.1+dfsg-3+deb9u2 (now)]
2) uim-anthy [1:1.8.6+gh20161003.0.d63dadd-2 (now)]
3) uim-qt [1:1.8.6+gh20161003.0.d63dadd-2 (now)]
4) uim-utils [1:1.8.6+gh20161003.0.d63dadd-2 (now)]

以下のパッケージをインストールする:
【割愛】

以下のパッケージを現在のバージョンに一時固定する:
11) libanthy1 [1:0.3-8.1 (now, stable)]


以下のパッケージを更新する:

【割愛】

Leave the following dependencies unresolved:
【割愛】


この解決方法を受け入れますか? [Y/n/q/?]Y
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが削除されます:
anthy libqt5widgets5{a} uim-anthy{a} uim-qt{a} uim-utils{a}
以下のパッケージが更新されます:
【割愛】
以下の、インストールが完了していないパッケージが設定されます:
uim-mozc
以下のパッケージが推奨されていますがインストールされません:
【割愛】
更新: 10 個、新規インストール: 6 個、削除: 5 個、保留: 657 個。
アーカイブの 0 B/3,784 kB を取得する必要があります。展開後に 2,406 kB のディスク領域が解放されます。
先に進みますか? [Y/n/?] Y
【割愛】
uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: パッケージ uim-anthy の処理中にエラーが発生しました (--remove):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
dpkg: anthy: 依存関係に問題があります。しかし要求に従い削除しています:
uim-anthy は以下に依存 (depends) します: anthy ...しかし:
パッケージ anthy は削除されようとしています。

anthy (1:0.3-8.1) を削除しています ...
処理中にエラーが発生しました:
uim-anthy
E: Sub-process /usr/bin/dpkg returned an error code (1)
【割愛】
現在の状態: 10 個 (-1) 破損。


まだ、だめなようだ。今度は、uim-anthyか。
しかし、このanthyってなんだろう?と疑問が出てくるが、取りあえず削除♪


hoge@samurai:# aptitude purge uim-anthy
【割愛】
以下のパッケージが削除されます:
libanthy1{u} uim-anthy{p}
以下の、インストールが完了していないパッケージが設定されます:
uim-mozc
更新: 0 個、新規インストール: 0 個、削除: 2 個、保留: 668 個。
アーカイブの 0 B を取得する必要があります。展開後に 580 kB のディスク領域が解放されます。
以下のパッケージには満たされていない依存関係があります:
【割愛】

以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:

1) libqt5widgets5 [5.7.1+dfsg-3+deb9u2 (now)]
2) uim-qt [1:1.8.6+gh20161003.0.d63dadd-2 (now)]
3) uim-utils [1:1.8.6+gh20161003.0.d63dadd-2 (now)]

以下のパッケージをインストールする:

【割愛】

以下のパッケージを現在のバージョンに一時固定する:
【割愛】


以下のパッケージを更新する:

【割愛】


この解決方法を受け入れますか? [Y/n/q/?]Y
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが削除されます:
libqt5widgets5{a} uim-anthy{p} uim-qt{a} uim-utils{a}
以下のパッケージが更新されます:
【割愛】
以下の、インストールが完了していないパッケージが設定されます:
uim-mozc
以下のパッケージが推奨されていますがインストールされません:
uim-qt5
更新: 10 個、新規インストール: 6 個、削除: 4 個、保留: 657 個。
アーカイブの 0 B/3,784 kB を取得する必要があります。展開後に 2,332 kB のディスク領域が解放されます。
先に進みますか? [Y/n/?] Y
【割愛】
libqt5widgets5:amd64 (5.7.1+dfsg-3+deb9u2) を削除しています ...
uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: パッケージ uim-anthy の処理中にエラーが発生しました (--remove):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
uim-qt (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
update-alternatives: 警告: /usr/bin/uim-toolbar-qt5 の alternative (リンクグループ uim-toolbar のパート) が存在しません。alternatives のリストから削除しています
処理中にエラーが発生しました:
uim-anthy
E: Sub-process /usr/bin/dpkg returned an error code (1)
libuim-scm0:amd64 (1:1.8.8-4+deb10u2) を設定しています ...
libuim8:amd64 (1:1.8.8-4+deb10u2) を設定しています ...
libc-bin (2.28-10) のトリガを処理しています ...
【割愛】
現在の状態: 6 個 (-4) 破損, 666 個 (-3) 更新可能。



まだ、削除が足りない模様。


【割愛】
uim-qt5 パッケージはインストールされていないので完全削除されません
uim-qt5 パッケージはインストールされていないので完全削除されません
以下のパッケージが削除されます:
libanthy1{u} uim-anthy{ap}
以下の、インストールが完了していないパッケージが設定されます:
uim-mozc
更新: 0 個、新規インストール: 0 個、削除: 2 個、保留: 665 個。
アーカイブの 0 B を取得する必要があります。展開後に 580 kB のディスク領域が解放されます。
【割愛】
以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:

1) uim-utils [1:1.8.6+gh20161003.0.d63dadd-2 (now)]


以下のパッケージをインストールする:

【割愛】

以下のパッケージを現在のバージョンに一時固定する:

【割愛】


以下のパッケージを更新する:

【割愛】



この解決方法を受け入れますか? [Y/n/q/?]Y
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが削除されます:
uim-anthy{ap} uim-utils{a}
以下のパッケージが更新されます:
【割愛】
以下の、インストールが完了していないパッケージが設定されます:
【割愛】
以下のパッケージが推奨されていますがインストールされません:
【割愛】
更新: 8 個、新規インストール: 6 個、削除: 2 個、保留: 657 個。
アーカイブの 0 B/3,634 kB を取得する必要があります。展開後に 5,553 kB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] Y
【割愛】
uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: パッケージ uim-anthy の処理中にエラーが発生しました (--remove):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
処理中にエラーが発生しました:
uim-anthy
E: Sub-process /usr/bin/dpkg returned an error code (1)
【割愛】


これでどうだと思ったが、まだまだ足りない。
今度こそ、uim-anthyを削除出来るか?

hoge@samurai:# aptitude purge uim-anthy
【割愛】
以下のパッケージが削除されます:
libanthy1{u} uim-anthy{p}
以下の、インストールが完了していないパッケージが設定されます:
uim-mozc
更新: 0 個、新規インストール: 0 個、削除: 2 個、保留: 665 個。
アーカイブの 0 B を取得する必要があります。展開後に 580 kB のディスク領域が解放されます。
【割愛】
以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:

1) uim-utils [1:1.8.6+gh20161003.0.d63dadd-2 (now)]


以下のパッケージをインストールする:

【割愛】


以下のパッケージを現在のバージョンに一時固定する:

【割愛】


以下のパッケージを更新する:

【割愛】


この解決方法を受け入れますか? [Y/n/q/?]Y
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが削除されます:
uim-anthy{p} uim-utils{a}
以下のパッケージが更新されます:
【割愛】
以下の、インストールが完了していないパッケージが設定されます:
uim-mozc
以下のパッケージが推奨されていますがインストールされません:
uim-qt5
更新: 8 個、新規インストール: 6 個、削除: 2 個、保留: 657 個。
アーカイブの 0 B/3,634 kB を取得する必要があります。展開後に 5,553 kB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] Y
【割愛】
uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: パッケージ uim-anthy の処理中にエラーが発生しました (--remove):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
処理中にエラーが発生しました:
uim-anthy
E: Sub-process /usr/bin/dpkg returned an error code (1)
【割愛】


まだ、削除が足りないようで、思い切ってこれらを削除してみる。

hoge@samurai:# aptitude remove uim-utils uim-fep libuim-custom2 uim-gtk3 uim-gtk2.0
【割愛】
以下のパッケージが削除されます:
libanthy1{u} libuim-custom2 uim-fep uim-gtk2.0 uim-gtk3 uim-utils
以下の、インストールが完了していないパッケージが設定されます:
uim-mozc
更新: 0 個、新規インストール: 0 個、削除: 6 個、保留: 662 個。
アーカイブの 0 B を取得する必要があります。展開後に 2,055 kB のディスク領域が解放されます。
以下のパッケージには満たされていない依存関係があります:
uim-anthy : 依存: uim-utils (>= 1:1.8.6+gh20161003.0.d63dadd-2) インストールされません
依存: libuim-plugins (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

依存: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) いずれの利用可能なパッケージからも提供されていない仮想パッケージです

依存: anthy インストールされません
以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:
1) uim-anthy [1:1.8.6+gh20161003.0.d63dadd-2 (now)]

Leave the following dependencies unresolved:
2) task-japanese-desktop が uim-anthy を推奨



この解決方法を受け入れますか? [Y/n/q/?]Y
以下のパッケージが削除されます:
libanthy1{u} libuim-custom2 uim-anthy{a} uim-fep uim-gtk2.0 uim-gtk3 uim-utils
以下の、インストールが完了していないパッケージが設定されます:
uim-mozc
更新: 0 個、新規インストール: 0 個、削除: 7 個、保留: 661 個。
アーカイブの 0 B を取得する必要があります。展開後に 2,267 kB のディスク領域が解放されます。
先に進みますか? [Y/n/?] Y
【割愛】
libanthy1:amd64 (1:0.3-8.1) を削除しています ...
uim-gtk2.0 (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
uim-gtk3 (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
update-alternatives: /usr/bin/uim-toolbar (uim-toolbar) を提供するために自動モードで /usr/bin/uim-toolbar-gtk3 を使います
libuim-custom2:amd64 (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
Error: in load: file "/usr/share/uim/lib/sigscheme-init.scm" not found
dpkg: パッケージ uim-anthy の処理中にエラーが発生しました (--remove):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
uim-fep (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
dpkg: uim-utils: 依存関係に問題があります。しかし要求に従い削除しています:
uim-anthy は以下に依存 (depends) します: uim-utils (>= 1:1.8.6+gh20161003.0.d63dadd-2).

uim-utils (1:1.8.6+gh20161003.0.d63dadd-2) を削除しています ...
処理中にエラーが発生しました:
uim-anthy
E: Sub-process /usr/bin/dpkg returned an error code (1)
libgtk-3-0:amd64 (3.22.11-1) のトリガを処理しています ...
libgtk2.0-0:amd64 (2.24.31-2) のトリガを処理しています ...
libc-bin (2.28-10) のトリガを処理しています ...
mime-support (3.60) のトリガを処理しています ...
【割愛】
現在の状態: 1 個 (-5) 破損, 662 個 (-4) 更新可能。



何か、表示が変わったので、ここで、apt --fix-broken install コマンドを入力してみた。

hoge@samurai:# apt --fix-broken install
【割愛】
依存関係を解決しています ... 完了
以下のパッケージが自動でインストールされましたが、もう必要とされていません:
【割愛】
これを削除するには 'apt autoremove' を利用してください。
以下の追加パッケージがインストールされます:
anthy kasumi libanthy1 libanthyinput0 libegl-mesa0 libegl1 libegl1-mesa libgail-common libgail18 libgbm1 libgtk2.0-0 libgtk2.0-bin libharfbuzz0b libicu63 libpcre2-16-0 libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5svg5
libqt5widgets5 libqt5x11extras5 libuim-custom2 libwayland-client0 libwayland-egl1 libwayland-egl1-mesa libwayland-server0 qt5-gtk-platformtheme uim uim-anthy uim-data uim-fep uim-gtk2.0 uim-gtk2.0-immodule uim-gtk3 uim-gtk3-immodule
uim-plugins uim-qt5 uim-qt5-immodule uim-xim
提案パッケージ:
gvfs qt5-image-formats-plugins qtwayland5
以下のパッケージは「削除」されます:
libanthy0
以下のパッケージが新たにインストールされます:
anthy libanthy1 libanthyinput0 libegl-mesa0 libegl1 libicu63 libpcre2-16-0 libqt5gui5 libqt5svg5 libqt5widgets5 libqt5x11extras5 libuim-custom2 libwayland-egl1 qt5-gtk-platformtheme uim uim-data uim-fep uim-gtk2.0 uim-gtk2.0-immodule
uim-gtk3 uim-gtk3-immodule uim-plugins uim-qt5 uim-qt5-immodule uim-xim
以下のパッケージはアップグレードされます:
kasumi libegl1-mesa libgail-common libgail18 libgbm1 libgtk2.0-0 libgtk2.0-bin libharfbuzz0b libqt5core5a libqt5dbus5 libqt5network5 libwayland-client0 libwayland-egl1-mesa libwayland-server0 uim-anthy
アップグレード: 15 個、新規インストール: 25 個、削除: 1 個、保留: 647 個。
1 個のパッケージが完全にインストールまたは削除されていません。
22.4 MB 中 0 B のアーカイブを取得する必要があります。
この操作後に追加で 62.5 MB のディスク容量が消費されます。
続行しますか? [Y/n] Y
パッケージからテンプレートを展開しています: 75%パッケージからテンプレートを展開しています: 100%

dpkg: `uim-data' のインストール によって壊れた uim-anthy の設定削除を考えています ...
dpkg: 問題ありません。(uim-data によって壊れた) uim-anthy の設定削除をします
【割愛】
進捗: [ 0%] [.........................................................................................................................................................................................................................] uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) を設定削除しています ...
uim-data (1:1.8.8-4+deb10u2) を展開しています...
古いパッケージ uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) 中のファイルを置換しています ...
進捗: [ 1%] [##.......................................................................................................................................................................................................................] uim-data (1:1.8.8-4+deb10u2) を設定しています ...
(以下略)


ヽ(^。^)丿イヤッホーーー!!!
キタ─wwヘ√レvv~(゚∀゚)─wwヘ√レvv~─ !!
進捗メッセージが出てきた!
一旦終わったところで、鬼のaptitude dist-upgradeコマンドを実行!

hoge@samurai:# aptitude dist-upgrade
【割愛】
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが更新されます:
【割愛】
以下のパッケージが推奨されていますがインストールされません:
【割愛】
更新: 647 個、新規インストール: 139 個、削除: 0 個、保留: 0 個。
アーカイブの 13.9 MB/599 MB を取得する必要があります。展開後に 962 MB のディスク領域が新たに消費されます。
以下のパッケージには満たされていない依存関係があります:
【割愛】

以下のアクションでこれらの依存関係の問題は解決されます:

以下のパッケージを削除する:
1) libcurl3 [7.52.1-5+deb9u9 (now)]
2) libtirpc1 [0.2.5-1.2+deb9u1 (now)]
3) mariadb-client-10.1 [10.1.44-0+deb9u1 (now)]
4) mariadb-client-core-10.1 [10.1.44-0+deb9u1 (now)]
5) mariadb-server-10.1 [10.1.44-0+deb9u1 (now)]
6) mariadb-server-core-10.1 [10.1.44-0+deb9u1 (now)]
7) mysql-server [5.5.9999+default (now)]
8) php7.0-curl [7.0.33-0+deb9u6 (now)]

以下のパッケージを現在のバージョンに一時固定する:
9) phpmyadmin [4:4.6.6-4 (now)]



この解決方法を受け入れますか? [Y/n/q/?]Y
以下の新規パッケージがインストールされます:
【割愛】
以下のパッケージが削除されます:
libcurl3{a} libtirpc1{a} mariadb-client-10.1{a} mariadb-client-core-10.1{a} mariadb-server-10.1{a} mariadb-server-core-10.1{a} mysql-server{a} php7.0-curl{a}
以下のパッケージが更新されます:
【割愛】
以下のパッケージが推奨されていますがインストールされません:
libfl-dev libpng-tools libqt4-sql-ibase libqt4-sql-mysql libqt4-sql-odbc libqt4-sql-psql libqt4-sql-sqlite libqt4-sql-sqlite2 libreoffice-help-ja libreoffice-l10n-ja libxml-sax-expat-perl mozc-utils-gui reportbug
更新: 646 個、新規インストール: 124 個、削除: 8 個、保留: 1 個。
アーカイブの 8,384 kB/594 MB を取得する必要があります。展開後に 766 MB のディスク領域が新たに消費されます。
先に進みますか? [Y/n/?] Y
【割愛】

dpkg: パッケージ iptables-persistent の処理中にエラーが発生しました (--configure):
依存関係の問題 - 設定を見送ります
処理中にエラーが発生しました:
opendmarc
netfilter-persistent
iptables-persistent
[ 0%] パッケージリストを読み込んでいます
[100%] パッケージリストを読み込んでいます
[ 0%] 依存関係ツリーを作成しています
[ 50%] 依存関係ツリーを作成しています
[100%] 依存関係ツリーを作成しています
[ 0%] 状態情報を読み取っています
[ 12%] 状態情報を読み取っています
[ 22%] 状態情報を読み取っています
[ 56%] 状態情報を読み取っています
[100%] 状態情報を読み取っています
[ 0%] 拡張状態情報を読み込んでいます
[100%] 拡張状態情報を読み込んでいます
[ 0%] パッケージの状態を初期化しています
[100%] パッケージの状態を初期化しています
[ 0%] 拡張状態情報を書き込んでいます
[100%] 拡張状態情報を書き込んでいます
[ 0%] タグのデータベースを構築しています
[100%] タグのデータベースを構築しています

現在の状態: 1 個 (-646) 更新可能, 57399 個 (-5) 新規。


とりあえず、opendmarc関連のエラーが出たけど、無事にアップグレードを終わらせました。
ただ、そのあとにメール関連でどえらい目に遭ったのだけど、アプリのアンインストール&インストールで設定も綺麗に直して終了。
半日があっと言う間に過ぎたが、何とかアップグレードが出来て良かったです。


しかし、この後色々なアプリに災厄が降りかかってきて、修復作業に入るのであった。。。
(明日に続く)


記事を評価してください(★1つ=悪い、★5つ=良い)
この記事の平均評価: (2人)
Posted by いぐぅ 06:00 | システム::linux | comments (0) | trackback (0)

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30